Overview Features Instructions Performance Forum Downloads Products OrderV4 Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
The team will post updates and news here

New Release 2.14 for V500 - Now With ApolloOSpage  1 2 3 4 

Thorsten B

Posts 17
30 Mar 2021 18:12


Well that's sorta off topic.. but Greetz to you

but regarding 2.14 for V500, could somebody elaborate if this works anywhere?


Marco Bruines

Posts 16
30 Mar 2021 22:29


Thorsten B wrote:

Well that's sorta off topic.. but Greetz to you
 
  but regarding 2.14 for V500, could somebody elaborate if this works anywhere?

I also have issues with Apollo Os on the V500v2.
 
With Apollo Os, i set my screen mode to standerd PAL hires after booting with shift pressed.
Then i have to reboot to be able to select a RTG mode. When i test a mode it works, saving to, but then after reboot the screen stays black.
ALso the 720p modes dont work under ApolloOs while testing.

With coffin indeed no issues. Also the 720p modes do work.

So for now back to my 3.1.4 setup where i have installed everything i need to use my A500+. This still works flawless too with 2.14. But a lot of games give grafical issues (Elf mania for example) but i assume the compatibility will get better.


Thorsten B

Posts 17
04 Apr 2021 23:27


Maybe Gunnar could explain how he made Apollo OS work on the 500 V2 with rtg etc?
  I also recognized that when a non bootable Floppy disk is in the drive/gotek the system will not boot the cf Card but show a screen asking to insert a cf/Boot disk.
  Is that expected behavior?

Edit: Managed to boot into RTG when starting without startup-sequence and executing s:Startup-sequence manually. Mode was 640x480 which seems to be the only mode with 35khz/72hz. Higher modes work only in 27khz and dont display (on my screen).
Still switching off/on still leads to the same behavior with no screen and now Im at the point where even starting without startup-sequence wont work. Will write the Image again to cf and try on ;)


Willem Drijver
(Apollo Team Member)
Posts 100
05 Apr 2021 11:54


We are working on improving Core compatibility for use with ApolloOS for V500-V2's. Thanks for reporting the graphical issues and keep an eye out in the Discord #vampire-accelerators channel for news.

Also we are still working hard at the V1200-V2 Core to be ready for release.

Roadmap Goal is to have full ApolloOS support across V2's and V4's.


Krzysztof AT

Posts 38
06 Apr 2021 22:58


I finally got my USB Blaster by Kamami. Succesfully flashed my V500 with newest Core 2.14, but i have few problems. I have SAGA 2.5.1, trying to install Kickstart by vampireflash and i can't. It supports only cores 2.10 to 2.13. I can't find any newer vampire flash. Is there any newer driver?
  I give a try to install kick 3.1 in 2.12 core, and I see only my first partition with it. The rest is NDOS. I'm afraid that will be the same with 2.14. Best way I think would be extract Kick from 2.12 and install to 2.14. Is there any way to do it?


Thorsten B

Posts 17
07 Apr 2021 18:21


Why not use VampireMap instead? Doesn't It work?


Krzysztof AT

Posts 38
07 Apr 2021 21:37


I have to admit I haven't tried. I assumed that flashing ROM would be better solution. Anyway, it doesn't solve NDOS partitions problem. I checked Vampiremap with 2.12 core and kick 3.1. Still have only boot partition.


Thorsten B

Posts 17
07 Apr 2021 22:07


Well I only tried Vampiremap with 3.1.4 and it worked flawlessly. I still hope for Apollo OS to magically merge with 3.2 and become a stable killer OS :)


UP Josh

Posts 4
10 Apr 2021 02:38


Hello all. So what Im reading here (sorry just got my v1200 and getting up to speed as I use my v500 with 3.1 and happy with that) is that
1) 2.14 is not released for the V1200 yet so the v1200 I just opened probably still has Kickstart 3.10 (3 dot ten) on it?
2) Can I boot workbench 3.1.4 on it or should I stick with Workbench 3.1?
3) I imagine without apollo rom in the core I cant boot Apollo OS correct? I could run Coffin yes but honestly I like a slimmer 3.1.X.
4) When core 2.14 is released with Apollo rom will it be able to boot 3.1.4?
5) Can I download AROS image and run it off the AROS website? Probably not as it seems the download says its for the Vampire V4
6) I cant find where to download the AROS rom and flash it to the V1200 or do I have to buy it? If I have to buy it I cannot find a place to do so. Maybe I shouldnt flash the AROS rom to the V1200 because there is a special rom needed .
7) I do see the 2.14 core in the downloads section of this forum but its the JIC version requiring a USB blaster. Is there an EXE version? I can only find 2.12 as an EXE. I have a USB blaster and I have flashed a JIC to the V500 v2+ before but Id rather not tear it open if i dont have to.

Thanks for any feedback!!! Cant wait to get this thing rocking but asking questions first before I bork the hell out of it and waste time breaking things.


UP Josh

Posts 4
10 Apr 2021 04:42


Also Im reading that in 2.12 core available for download the vampire v1200 ide is disabled. 2.13 fixes this. The thread says 2.13 should be released for the v1200 any day but that was in February. Any download for 2.13? Thanks


Stefano Briccolani

Posts 569
10 Apr 2021 07:35


V1200 core 2.13 was posted on this forum by Simo. And doesn't require the usb blaster.
  If you want to use 3.1.4 there's no problem. Just avoid to install the mmulibs and disable the checkinstall on startup sequence (you obviously need to VampireMap the 3.1.4 kick on startup).
  With Aros kick you'll still be able to map any kickstart so don't worry about that.
  Coffin maps a legacy kick on startup so no problem with Coffin too.
  You can run ApolloOS on your v1200 but only from the Amiga IDE (this i think will be resolved with core 2.14).
  So, plenty of options for you.
 


Vojin Vidanovic
(Needs Verification)
Posts 1896/ 1
10 Apr 2021 19:02


UP Josh wrote:

    1) 2.14 is not released for the V1200 yet so the v1200 I just opened probably still has Kickstart 3.10 (3 dot ten) on it?
 

 
  Every V2 Vamp has a bit updated Kickstart to plain Amiga kickstarts with Apollo needed dependencies. Future versions will come with AROS KS. Its anyway best to softkick whatever is needed for certain OS as opossed to flashing its ROM.
 
 
UP Josh wrote:

    2) Can I boot workbench 3.1.4 on it or should I stick with Workbench 3.1?
 

 
  You can but you need to mapROM KS 3.1.4 for A1200 (and A1200 version only, do not buy A500 etc. versions for use with V2, independently is it V1200)
  and a bit further Remus handling might be required, as explained here
  https://wiki.apollo-accelerators.com/doku.php/os:amigaos:v3.1.4
 
 
UP Josh wrote:

    3) I imagine without apollo rom in the core I cant boot Apollo OS correct? I could run Coffin yes but honestly I like a slimmer 3.1.X.
 

 
  With current ROM you can boot Coffin or any AmigaOS 3.x except 3.1.4 that needs newer 3.1.4 KS. For 1.x and 2.x you need to softkick respected KS
 
  ApolloOS is becoming V2 ready (as newer V2s will also have AROS ROM) and I suppose AROS ROM will be provided with it when its fully V2 ready
 
 
UP Josh wrote:

    4) When core 2.14 is released with Apollo rom will it be able to boot 3.1.4?
 

 
  Its not core dependent, you can boot it even now, see 1)
  See KS section of FAQ
  https://wiki.apollo-accelerators.com/doku.php/os:amigaos:start
 
 
UP Josh wrote:

    5) Can I download AROS image and run it off the AROS website? Probably not as it seems the download says its for the Vampire V4
 

 
  You can try official AROS m68k and its ROM
  EXTERNAL LINK    or AROS Vision
  EXTERNAL LINK   
  ApolloOS is a bit different Vampire specific AROS distro that would be best used with Vampire specific AROS ROM (Currently V4s are shipped with it)
 
 
UP Josh wrote:

    6) I cant find where to download the AROS rom and flash it to the V1200 or do I have to buy it? If I have to buy it I cannot find a place to do so. Maybe I shouldnt flash the AROS rom to the V1200 because there is a special rom needed .
 

 
  Use MapROM for fail safe, as explained
  https://wiki.apollo-accelerators.com/doku.php/system_tools:kickstarts
 
  You can find standard AROS ROM (non Vamp specific) on AROS floppy
  EXTERNAL LINK   
  It sounds confusing, but there is V4 Boot loader that manages it perfectly, or its best to restrict to one OS.
 
  I decided for AmiKit and Coffin, will try ApolloOS once I get larger card. But I am one of laisly guys that like to strip large distros of uneneeded files rather then building my own custom OS from scratch. No doubt, second slower route, always yields higher risks but better results.
 
  What I find great about Coffin (and should be with ApolloOS too) is that many things are preconfigured and Vampire specific software is preinstalled.
 
  If you use your own AmigaOS installing SAGA drivers first is a must
  http://wiki.apollo-accelerators.com/doku.php/saga:updates

Also Picasso96 is a must for OS 3.x!

 
  and browse a lot of FAQ topics to prepare
  http://wiki.apollo-accelerators.com/doku.php/system_tools:start


UP Josh

Posts 4
11 Apr 2021 18:32


Thanks for the comprehensive reply! I will use maprom. My legal 3.1.4 a1200 rom images came from Hyperion as two files: hi and lo because of course the a1200 has two rom chips for 32bits. Are there instructions for joining these files into one file for maprom? Maprom appears to take one main kickstart rom file as an argument (and then allows you to chain extra after). Ill look at remus and romsplit to see if either can thread these two files back together too.


UP Josh

Posts 4
11 Apr 2021 19:53


Ha! Disregard my previous question. I found the maprom/emulation rom file in the hyperion archive file. I totally missed it.


Peter Heginbotham

Posts 197
14 Apr 2021 12:09


Gunnar von Boehn wrote:

Release 2.14 is available for V500 Accelerators.
   
  This release gives you the latest Core improvements and comes bundled with ApolloRom.
   
  Using the Bootloader any AmigaOS can be loaded and of course you can run our ApolloOS distro:
 

With the new 2.14 core and the default ApolloRom will an existing system boot into its current installed OS e.g. 3.1.4 or CoffinR58 without the need to change anything?



Oliver Mohr

Posts 14
15 Apr 2021 13:53


I experienced that Coffin R58 works under the ROM included in Core 2.14. I didn't check OS 3.1.4. But the problems I had with Core 2.14 were that I wasn't able to map a ROM anymore. I wasn't able to flash a ROM and I wasn't able to flash the core back to e.g. 2.12 per software. Nothing of that was working! I had to use my USB-Blaster (for which Windows wasn't able to find a driver ... what the hell ... I had to search for an old driver but was successful fortunately)! With the Blaster I flashed back to Core 2.12 and stay with it by now.


Oliver Mohr

Posts 14
15 Apr 2021 13:56


By the way: my Vampire is a v500 v2+ ... ;-)


Mateusz S.

Posts 50
28 May 2021 21:55


Can I see the changelog somewere? Are there any performance improvements? Thanks!


Antonio la Marca

Posts 6
19 Jun 2021 13:58


Hello ,I dont understand why Nobody can answer the Question what is the advantages for Vampire V2+ Core 2.14

I have installed Core 2.14 but it is not so fast then 2.12
So what is the Point to install 2.14 ?

Is the stability better or the compatibility for older Software ?

Please answer the Questions !

Thank you for the real good Hardware for Amiga 500 !

Regards



Gunnar von Boehn
(Apollo Team Member)
Posts 5323
19 Jun 2021 16:02


Antonio La Marca wrote:

Hello ,I dont understand why Nobody can answer the Question what is the advantages for Vampire V2+ Core 2.14

The change is the ROM, the included legal and free ApolloOS-Rom

posts 65page  1 2 3 4