Overview Features Coding Performance Forum Downloads Products OrderV4 Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Questions and Answers for AMIGA Workbench or Coffin

Error When Creating/formatting New Partition.

David Ingebretsen

Posts 1
30 Jan 2023 18:10


I have searched Discord and this forum and found a few threads discussing this, but no firm solutions. At least nothing that works for my setup.
 
  I have a new V4+ Standalone with 9.2. 128 Gb CF card.
 
  I want to expand the supplied disc space to the full 128 Gb on the CF Card and then create one (or multiple if need be) partitions so I can install other software. The two partitions are pretty much full with wonderful stuff, but little room for other software, etc.
 
  Before I did anything else, I imaged the CF card with Win32DiskImager. Amazing application.
 
  Here is what I did:
  1. I expanded the disc using the supplied Apollo utility. This worked fine. Rebooted.
 
  2. Using HDToolbox, I created a new partition. I labeled it DH2:. I tried multiple different sizes from 1.0Gb to the full remaining disk space (edited to reflect I expanded the size I tried).
 
  3. I used the default SFS file system. The same file system on DH0: and DH1:.
 
  4. I saved and exited. I tried simply quitting and manually rebooting as well as selecting the "Reboot" option. Here's where it got frustrating...
 
  On reboot, I would get a plain white screen, or it would try to load workbench, etc. and I would get an error dialog:
 
  Software Failure!
  Program Failed
  Task: 0x025A5848 - WBDock
  Error: 0x80000006 - CHK instruction error
  PC: 0x00000012
  Wait for disk activity to finish.
 
  On the rare occasion it would finish booting, trying to do anything caused the system to hang.
 
  Here's what I did next:
  1. Held both mouse keys down, booted to Early Startup Control.
 
  2. Disabled DH2:. The system booted fine and all good, but no DH2: (obviously).
 
  3. I booted to Early Startup and booted with no startup-sequence. Great, CLI. I used the SFSFormat command and finally got DH2: formatted. This worked with all the different sized partitions I tried.
 
  4. Rebooted. I kept getting the above "Software Failure!" error or just an unstable system probably 3 out of 4 reboots. I was never able to get a stable system with a third partition of any size.
 
  I'm back to the original image now.
 
  I read a thread here:
  EXTERNAL LINK 
  Where Michael MiB referred to a script on the disk: "Stuff:Expert/Prepare..." but I find no such volume, directory, or script. Can anyone help me get a stable system with a new partition? I'm fine with multiple small ones, one or two big ones, I just want some room to install some of what I want to have available.
 
  Thanks!
 
  David


Huggy One

Posts 8
27 Mar 2023 19:24


Hi David ! Any answer to this problem ? iíve got the same problem with my Apollo OS 9.3Ö


Henrich Raduska

Posts 61
28 Mar 2023 16:57


Maybe it's a WBdock problem, try disabling it.

posts 3