Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Questions and Answers for AMIGA Workbench or Coffin

Envoy Users Here?page  1 2 

Master APEX

Posts 34
23 Jun 2020 16:51


Hello,
all my Amigas are using Envoy 3.1, or should use it. :)
Are here any successfully Envoy users?

My problem is, it is only not working stable on my A600 Vampire and A500 Vampire.
It is working rocking stable on my A2000/030, CD32 SXPro and Peg OS4.1.

The program use 68000 binaries. Listening a directory on the mounted device or copying some files leads to an ultimate freeze on the Vampire Amiga.
My last idea, I invested many days in research to find differences, is to test the turtle mode.

Any hints? Ideas?


Master APEX

Posts 34
23 Jun 2020 21:47


100 views but no one is using this great software?


Tim Waite

Posts 25
24 Jun 2020 04:03


Now I want to.


Smartroad 78

Posts 49
24 Jun 2020 07:25


I've no idea what it is! Google searches don't turn up anything using the keywords I can think of lol


Nick Fellows
(Apollo Team Member)
Posts 30
24 Jun 2020 09:05


my google searches led me to believe its some sort of samba client to enable network file share.


Peter Heginbotham

Posts 186
24 Jun 2020 09:08


smartroad 78 wrote:

I've no idea what it is! Google searches don't turn up anything using the keywords I can think of lol

EXTERNAL LINK


Ray Couzens

Posts 67
24 Jun 2020 09:14


A quick search and I found the following article. Scroll down to locate "File System 3 - Envoy" and there is a description of it's networking capability.  Not an application I have used or even heard of before.

EXTERNAL LINK 



Ray Couzens

Posts 67
24 Jun 2020 09:14


Peter Heginbotham wrote:

smartroad 78 wrote:

  I've no idea what it is! Google searches don't turn up anything using the keywords I can think of lol
 

 
  EXTERNAL LINK 

Snap!


Master APEX

Posts 34
24 Jun 2020 09:44


Very sad. I have Envoy 3.1 on 6 Amigas installed.
There is no way for a better file exchange between Amigas.


Andy Hearn

Posts 302
24 Jun 2020 09:58


that looks great! i remembered the Envoy name from the dim and distant past but nothing further... I guess i never had the hardware to check it at the time.

thanks for the education, now i want to get this, and more than one amiga on and working at once!


Ali B.

Posts 19
24 Jun 2020 22:31


Wow, thanks for reminding! I was amazed by envoy capabilities aside file sharing. We had our Amigas connected via serial line. I have to check the version I used. It might have been pre 2, as I think I remember connecting with an A1000.


Master APEX

Posts 34
26 Jun 2020 10:36


Seems that Envoy is only working in Turtle mode on a Vampire.



Ronnie Beck
(Apollo Team Member)
Posts 178
26 Jun 2020 11:55


Master aPEX wrote:

Seems that Envoy is only working in Turtle mode on a Vampire.
 

Maybe the software doesn't handle faster processors?  There is a handfull of amiga software which doesn't properly take into account the variety CPU speeds.

What exactly is the setup you are using?  What does "doesn't run stable" mean exactly?  It is hard to suggest something without know what exactly the problem is.


Henryk Richter
(Apollo Team Member)
Posts 119
26 Jun 2020 13:58


Master aPEX wrote:

Seems that Envoy is only working in Turtle mode on a Vampire.

I can confirm Apex'findings. I've tested with different Kickstarts, with and without Vampire specific extensions (i.e. including vanilla 3.1), different Network interfaces (SDNet variants, CNet.device on A1200), different vampirized Amigas (A500, A1200). Also, I've disabled  patches for testing purposes (MCP et al.). While Envoy works stable on high powered classic Amigas (both my A3000 and 4000 have 060s, clocked at 50/80 MHz), it crashes on Vampires. The symptom seems to be trashed memory.

It might be of interest that the crashes happen randomly on directory and file attribute read operations (i.e. load a remotely mounted directory within DOpus).

It's rather sad. Envoy is quite handy for transferring files between Amigas.


Master APEX

Posts 34
26 Jun 2020 14:55


Envoy is running here on 030 and 060 Amigas next to Peg2 emulating a 020.
The Vampire Amigas are crashing totally on listing directors or copying files.



Master APEX

Posts 34
27 Jun 2020 10:41


Will a core developer take a look on this?
Heinz Wrobel was an AmigaOS core developer, so I assume the problem is not only Envoy related. Could be a good testcase for improving the core, like with the Elude demos.


Master APEX

Posts 34
28 Jun 2020 17:40


There are 2 workarounds possible:

1. Run the Vampire in TURTLE mode and Envoy is working perfect.

2. Do not mount other Amiga drives on the Vampire machine, but allow access to all
drives from another Amiga (non-Vampire).

V500/V600/V1200 mounting other drives -> A4000 leads to the freeze of the Vampire system. But A4000 mounting Vampire drives -> V500/V600/V1200 is working.

So there is a solution, would be still interesting why ENVOY is running amok. :-)



Gunnar von Boehn
(Apollo Team Member)
Posts 4796
28 Jun 2020 17:44


Hallo Apex,

Do you by chance have Envoy sources?
Would you mind coming to our SLACK channel to more direct help us with some tests?


Master APEX

Posts 34
29 Jun 2020 15:17


Sources never got released from Heinz Wrobel. He is not interested in the community or his old software, sadly. Test is really easy, but I will try to get in.
  In think Envoy is really important if you have than 1 Amiga. :) And it is a really native Amiga Software.
 
You can add apex add a1k.org


Master APEX

Posts 34
03 Jul 2020 15:12


After some more days of testing I can confirm that ENVOY will only work in Turtle Mode 100% stable.

posts 21page  1 2