Overview Features Coding Performance Forum Downloads Products OrderV4 Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

V2 Updatespage  1 2 3 

Nick Fellows

Posts 134
29 Dec 2021 10:03


The only solution for the future is to create cores with free Apollo-Rom included. We are working on this - but this takes some time.

This seems like an unsustainable method - are you looking into alternatives?


E Penguin

Posts 46
30 Dec 2021 10:54


I like the idea of AROS but it would be nice to be able to retain the ability to replace it with our own kickstart files (or custom ROMs for the adventurous)


Havard Spring

Posts 6
30 Dec 2021 11:07


Yes - would it not be possible to have an option to copy from the host machine on first boot?


Steve Hodson

Posts 25
30 Dec 2021 19:58


Havard Spring wrote:

  Yes - would it not be possible to have an option to copy from the host machine on first boot?
 

 
  You can use VampireMap to map a regular kickstart at first boot *or* use VampireFlash to write it to the Vampire Flash for a more permanent solution.


Henrich Raduska

Posts 55
01 Jan 2022 12:48


I can't believe the creators of 68080 can't update the CPU core without updating kickstart.


Peter Heginbotham

Posts 209
01 Jan 2022 17:37


FRAXINOUS Eric wrote:

Gunnar von Boehn wrote:

 
  Many people found the several websites confusing and ask us to "consolidate" this.
  This is exactly what we are doing.
 
 
  Please understand the downloads for V1200/V600/V500 can currently not be provided for legal reasons.
 
  As you know in the cores of V1200/V500/V600 used to contain a licensed Kickstart file.
  But who owns the right to give out licenses is currently unclear and distributed in court.
 
  These legal battles drag out now since years.
  As we do not want to be involved in these court cases.
  Therefore we can not provide links to these files anymore.
 
  The only solution for the future is to create cores with free Apollo-Rom included. We are working on this - but this takes some time.
 
 

  one more step to remove the v2 lineup ... hyperion is the owner of the amiga kickstarts ... they even sell version 3.2 ... After what you do on the v2 lineup, i would never buy a v4. ... it’s a shame…
 

I think the FPGA chip used in the V2, going EOL (End of Life) was a bigger reason for ending the v2 range.

I belive in the early days of the vampire you had to provide proof you had valid a 3.1 rom. Then i believe the project licenced the rom from Cloanto which is now in legal dispute, hence the reason why the V2 updates have been pulled.

Back to the orginal topic, I would really like a final v2 core update (hint 2.15) and a supported SAGA driver set but understand the complexities of fixing the bug and adding any enchancements while removing the 3.x rom and replaceing with the AROS rom



Antony Coello

Posts 128
03 Jan 2022 20:16


Peter Heginbotham wrote:

 
    I belive in the early days of the vampire you had to provide proof you had valid a 3.1 rom. Then i believe the project licenced the rom from Cloanto which is now in legal dispute, hence the reason why the V2 updates have been pulled.
   
    Back to the orginal topic, I would really like a final v2 core update (hint 2.15) and a supported SAGA driver set but understand the complexities of fixing the bug and adding any enchancements while removing the 3.x rom and replaceing with the AROS rom
   
 

 
  I still think the team should put an onboard ROM check (for a real ROM IC) in the bootup. Its then not (legally) their fault if someone chooses to circumvent/hack this.
 
  (This is basically the equivalent of a shop worker not being illegally breaking the law when they sell tobacco to over 18s. The over 18s can then choose to give the tobacco to under 18s, but then the shopkeeper can not really be held responsible).


Nick Fellows

Posts 134
04 Jan 2022 15:25


I honestly think the AROS development is the right way to secure a future, its the fact that its open source

1) AROS is unencumbered by legal issues #Legality
2) If Apollo Team go belly up ( hopefully not ) development can continue and be picked up by someone else. #Protection
3) It secures a target platform that could be expanded to be compatible with other platforms eg PiStorm (shock horror) #Outreach

4) There is no future in proprietary platforms, collaborative work is the way forward, as is a shared vision rather than one or two peoples opinionated vision. #Collaboration


Henrich Raduska

Posts 55
05 Jan 2022 09:17


Try to explain to me what the patch CPU has to do with kickstart. What needs to be upgraded is the "wiring" for the FPGA, which defines the 68080 CPU and I/O devices.


Nick Fellows

Posts 134
05 Jan 2022 15:15


The only reason I can think of would be if there is code on the ROM that has been tightly coupled or optimised for the 68080 instruction  set. But this would only exclude the ROM from being used on non 68080 CPUs. This is a dangerous precedent known as "vendor lock in".


Smartroad 78

Posts 114
05 Jan 2022 20:31


Does the Kickstart need to be included with the firmware for the accelerator? My Blizzard PPC/040 card just maps the kickstart into RAM, can't the Vampire just do something similar, copy the built in kickstart to flash? Either copy the kickstart on the board or give people the option to flash their own on the card?

I am concerned, as a V2 owner for my A1200 that since the V4 accelerators have been announced the V2's and all supporting software for them, seems to have gone.

Not trying to be negative (although I understand it may read that way) but I spent a fair bit of money on this item and now the wiki is gone with all the drivers and support that the card needs. There isn't even a placeholder to say something like "This site is no longer used please go to *insert web address* to find out information about the V2 cards"


Darren Eveland

Posts 61
06 Jan 2022 00:44


FRAXINOUS Eric wrote:

  Don't bother to cry about the v2 line, they are dead now...
 

 
  He has every right to get support. Some of us only recently purchased the V1200.  It came with the 3.1 licensed roms, and it was legal to buy it then, so it should come with support as it was legally purchased at the time.  At minimum links should be provided to legitimate purchasers.
 
  And personally I find your response offensive.  The V2 line is not dead.  They are perfectly usable for many of us and will be for years to come.


Gunnar von Boehn
(Apollo Team Member)
Posts 5617
06 Jan 2022 10:14


Mark Breckell wrote:

Hi Gunnar, so where do people go for saga drivers and core updates and information about  the v2's for the A500 A600 and A1200, there is nothing about these product anywhere any more, It just feels like we have just been left in the cold with these products.

   
As you know, there are legal battle fought in court about the rights to Amiga OS. These battles rage since some years now. As long as these battles are fought there is a legal uncertainty.
These battles do affect the Amiga community and also us.
I'm sure that you fully understand that we do not want to be drawn into these legal battles. The V2 cores did use to include a licensed kickstart ROM. The legality of this licensed Kick is currently disputed in court.
We are forced by this to remove the V2 cores from our website.
We know that this is not optimal for Amiga fans, but we have no other choice.
 
We think that the best solution for the Amiga will be to create a free OS for Amiga. We work on this but this is a big task and needs a lot time. We work on creating cores for the V2 range which will be able to use the legal free new OS. We work on this.


Ivan Richardson II

Posts 2
06 Jan 2022 22:13


V2 Cores can be found here:

EXTERNAL LINK 
Click on the "cores" link, then click on the folder for your device.  You will then be presented with a list of cores available for download.
 


E Penguin

Posts 46
11 Jan 2022 09:12


As long as it's easy enough to update/over-write the default KS with one of your own then I don't see it as a problem either way.


Nick Fellows

Posts 134
11 Jan 2022 11:38


Currently if you change the rom to say 3.2 you lose one of the IDE ports. In other words, today, the V2 / V1200 is not future proof, nor will it be until it plays nice with real "Amiga" KS roms.
 
  It seems likely to me that we will eventually be "locked in" to the AROS/ApolloOS Kickstart replacement Rom , which isnt a particularly bad thing since AROS is open source there is at least an unencumbered operating system free from the legal bullshit that the official Amiga vendors have brought on themselves by failing to work together. But this could be a bad thing if Apollo team also repeat history and fail to work with other community projects to ensure healthy & diversity. Our way or the highway isnt the right path imho. The fact they have chosen to work on the open source version is!
 


Gunnar von Boehn
(Apollo Team Member)
Posts 5617
11 Jan 2022 22:46


nick fellows wrote:

Currently if you change the rom to say 3.2 you lose one of the IDE ports. 

This is not true.
You can use another Rom and continue to use the IDE ports.



Nick Fellows

Posts 134
13 Jan 2022 08:23


That is contrary to my personal experience and what i've been advised on the discord channel. Is there a guide i can follow that explains how to make this work? My experience is as i described.


Gunnar von Boehn
(Apollo Team Member)
Posts 5617
13 Jan 2022 10:10


nick fellows wrote:

what i've been advised on the discord channel.

What is your nick on Discord?


Nick Fellows

Posts 134
13 Jan 2022 13:43


polyp2000 .

In the discord theres actually a discussion where you explain the need for the flashed kick to include support for the second IDE.

above in this thread you said
"This is not true.
You can use another Rom and continue to use the IDE ports."

These two things seem mutually exclusive to me, unless there is another way to get the second IDE supported without needing support for it on the rom.

"[9:58 AM]
i think there are 3 options
[9:58 AM]
a) use the orignally included Kick 3.10 with dual IDE support buildin
[9:59 AM]
b) use the mobo IDE controller and a kick not enabling the 2nd
[9:59 AM]
c) flash a kick with the recent flashtool which should add support for the 2nd IDE"



posts 44page  1 2 3