Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

Vampire V4SA - SD Card Issue After Core Update

Marek Petkov

Posts 7
16 Oct 2020 20:24


Hi,

I updated my V4 via the USB Blaster with the 2020/10/06 jic, then updated the SAGA driver to ver 2.4.3.

Today I needed to transfer some files via the SD card, but I keep getting this error:

* Mountfile "AROS:Storage/DOSdrivers/SD0" is invalid *

I was using the very same SD card before without any issue.

Hints would be appreciated greatly. Thanks in advance!

Marek


Gunnar von Boehn
(Apollo Team Member)
Posts 4964
17 Oct 2020 07:11


Marek Petkov wrote:

Hi,
 
  I updated my V4 via the USB Blaster with the 2020/10/06 jic, then updated the SAGA driver to ver 2.4.3.

What OS do you use?
ApollOS which was shipped with the V4?


Marek Petkov

Posts 7
17 Oct 2020 08:53


Hi Gunnar,
 
  Thanks for your reply. Yes, I am using the original V4SA ApolloOS, with no modifications. I just did the updates described in my initial post.
 
  One more information - after I flashed the jic, the machine started to show some green copper-like strips upon each boot for a brief moment and then continues to boot normally.
 
  Thanks & Regards,
 
  Marek


Gunnar von Boehn
(Apollo Team Member)
Posts 4964
17 Oct 2020 09:15


Marek Petkov wrote:

Yes, I am using the original V4SA ApolloOS, with no modifications. I just did the updates described in my initial post.

The SAGA drivers are only needed of OS3, they are not needed for ApollOS. Please don't install them on ApollOS. By installing them you broke your ApollOS.
 
 


Marek Petkov

Posts 7
17 Oct 2020 15:14


Hi Gunnar,
 
  Aggrhhh, noobish of me!
 
  Is there any quick and convenient way to restore the proper files, once the damage has been done?
 
  The jic re-flash should sort that out, correct?
 
  Thanks again,
 
  Marek


Gunnar von Boehn
(Apollo Team Member)
Posts 4964
17 Oct 2020 22:05


Marek Petkov wrote:

The jic re-flash should sort that out, correct?

I understood you that you copied OS files from OS3 to ApollOS... overwriting the original files.
I think you need to repair your CF copy of ApollOS now.


Marek Petkov

Posts 7
19 Oct 2020 19:27


Thanks Gunnar,

If anybody else ends up like me, just have a look at this post to get things right again + secure the outstanding 16GBs of your SD card,, if you got the 32GB one (credits to Cutter for the vid):

EXTERNAL LINK 
Regards,

Marek

 

posts 7