Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

Vampire A600 V2 and WHDLoad 18+ Not Working

Henrique Olifiers

Posts 8
29 May 2020 20:38


Hi folks! Sorry if this topic has already been covered, I couldn't find any references to it.

I've noticed that starting with version 18.3, WHDLoad explicitly supports the Vampire, likely unlocking more performance for 3D games that in the past run in slow mode (4D Driving, Frontier etc.)

Problem is, I can't seem to be able to run either v18.3, v18.4 nor v.18.5 versions of WHDLoad. It crashes badly with every game.

Version 16.9 and older is absolutely fine. It's just precisely when WHDLoad starting to implement Vampire support (detected as 68040 instead of 68020) that things stop working.

I have a power-patched A600 V2 with the latest Gold, OS3.9. Tried a lot of WHDLoad options such as ExChipMem with no luck.

Anyone has a tip for this one? ;)


Vojin Vidanovic

Posts 1697
29 May 2020 20:45


Dont have immidiate solution, but if you are so brave, why not trying latest 18.6 beta?
  EXTERNAL LINK  (extract on top off latest WHDLoad package)


Henrique Olifiers

Posts 8
29 May 2020 21:43


You dare to suggest a Vampire user lacks in bravery? =D

Right, some progress! I'm using a 1084S, RGB only (not DIGITAL-VIDEO). With 18.6 I got a black screen, no more garbage. So, I plugged an DIGITAL-VIDEO and went to launch WHDLoad via DIGITAL-VIDEO. Now there's an error message (yey!) to lead us forward!

I've getting a DOS-Error #205

Which may lead you to think I'm missing a Kickstart on my Devs. But I remind you that I get it all to work on 16.9 and older, I seem to have all relevant Kickstarts on Devs -- unless I'm missing a specific one required for the Vampire.

Any clues? ;)




Henrique Olifiers

Posts 8
29 May 2020 22:38


OK, solution found -- embarrassing to say the least.

I've got a cracked keyfile on the S directory (whdload.key). No idea how this ended up there, probably leftover from an eBay CF Card adapter with included ready-made CF card from which I started my system from years ago.

Even though I have the care to buy as much legal stuff as I can to help support the community (Cloanto, AmigaOS3.9, 4.1 etc.), I end up with something like this in the system.

Anyway, hope this embarrassing episode serves someone else down the line with a similar issue.

Thanks and sorry for disturbing!



Vojin Vidanovic

Posts 1697
29 May 2020 22:40


Glad solution has been found!
 
  Pay attention, indeed you may need some older KS files for some titles
  EXTERNAL LINK

posts 5