Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

So, I Got My V1200 Today ... : /page  1 2 

Knight Stone

Posts 91
24 Feb 2020 14:52


And i have to say, I am really unimpressed, thoroughly disappointed, maybe it's me, maybe i am doing something wrong?

I am running in a 2B board, recapped, a 200W SFF ATX PSU, a 32GB CF card, running a simple and plain install of WBClassic (Not Coffin OS) and running through Amiga RGB to a CM8833 M2, and there are some issues.

Not being able to use the PCMCIA is a pain, although i understand there is an updated firmware for this, I can't boot at all from the onboard IDE, although the V2's IDE is meant to be faster, well, if you a 200K bump faster, then it's faster. I am not sure if the firmware upfdate fpr this was released before my card was sent, on the 17th of Feb, i would hope not.

Alot of games won't run, Alien Breed 3D, Alien Breed 3D 2, Dune, are the only 3 i have tested and they either give me a black screen, and start after a lengthy pause, only to just die immediately.

But the worse thing, is the performance. I get the exact same benchmarks in Sysinfo and SysSpeed as i do with my V2 A600 as to be expected, but when i put this next to my other A1200, with an identical install, and an Apollo 1260, the Apollo absolutely wipes the floor with the Vampire. The problem appears to be redraw speeds. I haven't tested it over H.D.M.I and i dont intend to, i want to use it over RGB, but when i run tests like Beachball, TGT, Line test, Screen redraw, the Vampire is woefully slow, and even in SysSpeed, the Apollo 1260 blows the Vampire away. Running the intuition tests, and graphics tests etc in SysSpeed, is like watching it on a stock A1200, when i put it next to my ACA 1233n , with a 68030 @40Mhz, it's beaten by that to. But synthetic benchmarks don't mean much, so running Frontier (from disk, and not WHDLoad) should save it, right? nope ... its a jerky framefest, and this is not what i expected, i can hear my Apollo 1260 laughing in the corner

maybe i am doing something wrong? but the RGB performance with this is awful. The Apollo 1260 is back in the Amiga, because at this stage, after testing, the Vampire V1200 is pretty much unusable at this stage.

not trying to be a dick, just my findings.




Igor Majstorovic
(Apollo Team Member)
Posts 317
24 Feb 2020 15:37


Hi, as said before, that's initial version of the core. Maybe you should flash some other versions published on this forum and then try. I wouldn't expect instantly to see everything perfect as it wasn't on V500 or V600. For better understanding, core you have in the card now have 16bit access to amiga so you can't expect much with that core. On top of that in that core there are several bugs we fixed later. With other cores you will get better results. Try them please. 


Knight Stone

Posts 91
24 Feb 2020 16:00


igor majstorovic wrote:

Hi, as said before, that's initial version of the core. Maybe you should flash some other versions published on this forum and then try. I wouldn't expect instantly to see everything perfect as it wasn't on V500 or V600. For better understanding, core you have in the card now have 16bit access to amiga so you can't expect much with that core. On top of that in that core there are several bugs we fixed later. With other cores you will get better results. Try them please. 

Hi Igor

Thanks for coming back to me, and for trying to be helpful, rather than defensive, it's appreciated.

I never knew the present core only has 16bit access, if i had known that, it might well have answered some questions, and would have went a long way to explaining the puzzling screen draw speed.

Is the core in an EXE format? or will have to buy a USB blaster to do this?

thanks again :)


Igor Majstorovic
(Apollo Team Member)
Posts 317
24 Feb 2020 16:09


One of the reasons why this project progress is because user comments, their tests and problem identification :)
  You will have to use USB blaster since those are beta cores. Still no official exe release. We have several bugs to fix before that happens...


Michael AMike

Posts 101
24 Feb 2020 16:43


Knight Stone wrote:

 
  maybe i am doing something wrong?
 
 

It would have been faster to flash the latest core, than to write the posting. :/



Renaud Schweingruber
(Apollo Team Member)
Posts 318
24 Feb 2020 17:38


That's actually one of the most interesting benefit of the FPGA technology from which we take advantage in our strategy : quickly bring hardware into customer hands and then provide continuous core updates.
If we had to ship hardware with the core in a "finished and final" state (I won't say ASIC to not distract the topic), probably none of us would have a Vampire today.

Providing constructive feedback is indeed the best way to make things move in the right direction.


Dma Con

Posts 12
24 Feb 2020 17:58


Would it be difficult to actually make a flasing tool, instead of providing the FPGA bitstream + flashing tool as one binary blob for selected release cores? Of course there is alway a risk of bricking your card and requiring to order an USB Blaster anyhow.
 
  But on the other hand, even though I do have an USB Blaster, I am not so fond of the idea to physically open the Amiga / remove the Vampire each time an intermediate core is released, which has significant improvements.
 
  No critique, just some points for consideration..
 
 


Knight Stone

Posts 91
24 Feb 2020 18:15


Michael AMike wrote:

Knight Stone wrote:

 
 
  maybe i am doing something wrong?
 
 
 

 
  It would have been faster to flash the latest core, than to write the posting. :/
 

oh would you now? and why should i care what you think?

I have ordered a USB blaster, and will give it a go, and I am well within my right, to post my findings on here. Strangely enough, the team didn't take it to heart, the only person who did was you. Easy to hide behind a keyboard though, right ?

I still stand by my original findings. 7/10 games i have tried don't work, and the team have admitted themselves, "there is still alot of work to do", and the card was sent with the original firmware, several days after a revised one was released, and it's not beyond the realms of possibility, that i should expect it to arrive with the newest core, is it?

go boil your head, troll


Sean Sk

Posts 328
24 Feb 2020 18:51


Come on guys, just chill out.
 
@Michael AMike:
Your comment was extremely unhelpful.
 
@Knight Stone:
Please don't stoop to his level. Anyway, thank you for posting your experience, I find these kind of things interesting. I have a V1200 on its way to me now, and it's helpful to read the experiences of others so that I know what to expect and what I might need to do to fix things. I hope more and more people share what they find works and what doesnt work.
 
Don't be put off by the current state of the core as things will dramatically improve over time and the team do rely on the helpful feedback of other Vampire users. I also have a V600 and have seen how much that has been improved over the last few years. Yeah sometimes you will come across some frustrating things but that is why this forum exists so that we can post our findings.


Michael AMike

Posts 101
24 Feb 2020 20:00


Knight Stone wrote:

       
    oh would you now? and why should i care what you think
       
   

 
     
  Comment:Because you're obviously judging something without having much clue - but I'm happy to help.
 
 
       
   
Knight Stone wrote:

       
    Performance in general & low chipmem speed vs. Apollo 1260
     
   

 
  Comment:Fixed in the last two updates - V1200 is the card with the best chipmem performance across all A1200 Tubocards.
 
 
 
       
   
Knight Stone wrote:

       
    Alot of games won't run, Alien Breed 3D, Alien Breed 3D 2, Dune, are the only 3 i have tested and they either give me a black screen, and start after a lengthy pause, only to just die immediately.
     
   

       
  Comment: All three games are working here - guess what - flash the last update and check the WHD settings.
       
 
 
 
   
Knight Stone wrote:

       
    go boil your head, troll
       
   

       
  Comment: Any other questions which I can google for you?
   
   
    Edit: Sorry, I'm better at flashing than quote.
   


Nixus Minimax

Posts 415
25 Feb 2020 08:24


Knight Stone wrote:
although the V2's IDE is meant to be faster, well, if you a 200K bump faster, then it's faster.

This may be a problem with your CF-card adapter or you don't enable fast-IDE. The V1200-IDE is at least three times the speed of the internal IDE. But if you are going to flash the PCMCIA-enabled core when your USB-blaster arrives, you will have to use the A1200-IDE anyway until there is a core that has both PCMCIA and V1200-IDE.

The problem appears to be redraw speeds.

Yes, this is indeed a problem of the 1st release core. It has been fixed some time ago as already mentioned on this thread. I think it would be nice of you to report back once you got your USB-blaster.

but when i run tests like Beachball

Beachball is slow? That would surprise me because it is not a benchmark test that is affected a lot by the OCS/ECS-type access to chipmem of the 1st release core.

running Frontier (from disk, and not WHDLoad) should save it, right? nope ... its a jerky framefest, and this is not what i expected, i can hear my Apollo 1260 laughing in the corner

This has been explained many times: do NOT use the Frontier WHDload slave, it disables the CPU caches by default which puts the 080 into turtle mode (approximately the speed of an unexpanded A1200). Just do a normal HD-install and run the game. Frontier does NOT need any WHDload.




Ronnie Beck
(Apollo Team Member)
Posts 158
25 Feb 2020 08:41


Knight Stone wrote:

Michael AMike wrote:

It would have been faster to flash the latest core, than to write the posting. :/

oh would you now? and why should i care what you think?
.
.
.
go boil your head, troll

Michael AMike's comment was not at all in the right spirit.  It _IS_ good that you posted here and sought help (after all that is a key goal of these forums) and that you simply didn't give up.

It is early days for the V1200 and you will receive many, many more updates.  Please let us know if you need assistance finding and installing these updates.  There is also a guide on installing the cores via a USB blaster here:

https://wiki.apollo-accelerators.com/doku.php/system_tools:installing_cores

We have an IRC channel #apollo-team as well as a group on slack.com called "apollo-team" if you would like real-time help.  Your feedback is valuable in helping us target specific games/software/scenarios to test.

Please let us know how you go with the update over USB Blaster.


Kriz Antikriz

Posts 10
28 Feb 2020 10:13


I am also waiting for my V1200, where can i order a USB blaster ? Are they only available from China, i see some on ebay from that area, not the easiest to get goods from there now..  Any links please ..

If we really need to flash all the time a USB blaster included would be nice ..


Jakub H.

Posts 28
28 Feb 2020 10:37


Kriz Antikriz wrote:

I am also waiting for my V1200, where can i order a USB blaster ? Are they only available from China, i see some on ebay from that area, not the easiest to get goods from there now..  Any links please ..
 
  If we really need to flash all the time a USB blaster included would be nice ..

I recommend this blaster

EXTERNAL LINK


Daniel Sevo

Posts 285
28 Feb 2020 10:41


Kriz Antikriz wrote:

I am also waiting for my V1200, where can i order a USB blaster ? Are they only available from China, i see some on ebay from that area, not the easiest to get goods from there now..  Any links please ..
 
  If we really need to flash all the time a USB blaster included would be nice ..

Couple of years ago I got some cheap ones ($5 each or so) from ebay and they worked fine actually Just make sure it says its compatible with Altera.
But as for including, I guess its like not getting a PSU with a Raspberry Pi. Yes you are going to need it, but a lot of people already have one so they would complain if they had to pay again for what they already have...



Kriz Antikriz

Posts 10
28 Feb 2020 10:53


Thanks, ok what about this, Looks ok ? https://www.ebay.com/itm/Mini-Altera-Usb-Blaster-Cable-For-CPLD-FPGA-NIOS-JTAG-Altera-Programmer-GM/262136733505?hash=item3d08911f41:g:aZwAAOSwb15b83NW


Knight Stone

Posts 91
28 Feb 2020 11:54


igor majstorovic wrote:

One of the reasons why this project progress is because user comments, their tests and problem identification :)
  You will have to use USB blaster since those are beta cores. Still no official exe release. We have several bugs to fix before that happens...

i flashed it to the X12 core with no PCMCIA, and it's like a different card. more much stable, and redraw speeds are up between 7% to 66% depending on the game/app. Its loads better  :) some games appear to run at stock speeds of an unaccelerated system, some games, like Buggy Boy are too fast to play  :) but AB3D is like silk, i mean, uber smooth.

I have a slight ripple going down the CRT screen on the X12 core, barely perceptible, but its a slight ripple that goes down the screen, constantly. the board has just been recapped. And sometimes when i quit a game or app, when i get back to WB, it only report 64MB of RAM, not 128MB, but a reboot fixes that.

Still some glitches with sound and gfx, but Doom on an Amiga, at 42fps with full music and sound? yes please  :)


Daniel Sevo

Posts 285
28 Feb 2020 14:11


Kriz Antikriz wrote:

Thanks, ok what about this, Looks ok ? https://www.ebay.com/itm/Mini-Altera-Usb-Blaster-Cable-For-CPLD-FPGA-NIOS-JTAG-Altera-Programmer-GM/262136733505?hash=item3d08911f41:g:aZwAAOSwb15b83NW

Looks a lot like the ones I got


Kriz Antikriz

Posts 10
02 Mar 2020 21:45


Anyone know anywhere in Europe i can get a USB Blaster ? China takes too much time for ordering now (for Ebay the seller might be gone for a month or more these days, or even dead in worse case scenario) ..


Knight Stone

Posts 91
02 Mar 2020 23:42


Kriz Antikriz wrote:

Anyone know anywhere in Europe i can get a USB Blaster ? China takes too much time for ordering now (for Ebay the seller might be gone for a month or more these days, or even dead in worse case scenario) ..

search on ebay for sellers local to you, not outside your country

posts 23page  1 2