Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

Three Newbie Questions

Jonas Thorell

Posts 7
11 Feb 2020 00:14


Hi there,

Three newbie questions if you don't mind.

1. When a reddish light lits up on the accellerator (A1200 version in this case), that's indicative of the so-called turtle-mode, right?
2. Is there a way to determine which core my system is running? I thought Vcontrol should be able to tell me that but it only tells ne "Undefined".
3. I tried to run the "VampireDemo2D" demo, but got the error "Sorry, this demo needs an AC68080 and AMMX V2." Which of course I have, especially considering that P96 + Saga + ammx-enabled datatype give me a very nice and speedy workbench. Sagadriver 1.7.1 and vampiregfx.card 1.29. Okay, not a dealbreaker in anyway, just an oddity.
4. Well, okay. 4 problems. Something complains about "wrong hardware" in a shell-window just before booting is complete. That is, I get it on my 15khz monitor attached to the standard RGB-connector (with the default resolution) just before the display switches over to my hdmi-vampire display. I've tried to find what is causing it, but no luck so far. Anyone with an idea of where to look?


Gunnar von Boehn
(Apollo Team Member)
Posts 4517
11 Feb 2020 06:53


Hello Jonas,

Can you please tell me 
What Kickstart are you using?
What Workbench are you using?


Jonas Thorell

Posts 7
11 Feb 2020 07:44


Gunnar von Boehn wrote:

Hello Jonas,
 
  Can you please tell me 
  What Kickstart are you using?
  What Workbench are you using?

Sure. 3.1.4 kickstart (custom, enhanced intution.library and icon.library added) and Workbench 3.1.4.1


Gunnar von Boehn
(Apollo Team Member)
Posts 4517
11 Feb 2020 14:09


Jonas Thorell wrote:

 
Gunnar von Boehn wrote:

  Hello Jonas,
   
    Can you please tell me 
    What Kickstart are you using?
    What Workbench are you using?
 

 
  Sure. 3.1.4 kickstart (custom, enhanced intution.library and icon.library added) and Workbench 3.1.4.1
 

I think you just explained the reason of your problem.
How do you load your selfmade ROM?
What happens if you NOT load this ROM but use the Vampire buildin?


Jonas Thorell

Posts 7
11 Feb 2020 15:01


Gunnar von Boehn wrote:

Jonas Thorell wrote:

 
Gunnar von Boehn wrote:

    Hello Jonas,
   
    Can you please tell me 
    What Kickstart are you using?
    What Workbench are you using?
   

   
    Sure. 3.1.4 kickstart (custom, enhanced intution.library and icon.library added) and Workbench 3.1.4.1
 

  I think you just explained the reason of your problem.
  How do you load your selfmade ROM?
  What happens if you NOT load this ROM but use the Vampire buildin?

I use vcontrol mr <path to kickstart-file> as the first line in s:startup-sequence (if memory serves about the syntax, not at home and can check right now).

I haven't tried with the built-in since I plugged in the hi-res monitor to the hdmi interface and configured SAGA. But before I had to use my custom one, or the computer would either lockup as in no response when clicking on icons or a complaint about a missing resource. Which resource wasn't clear.

But I'll try with the built-in again, or a default kickstart 3.1.4 without modifications to see if it works now.



Gunnar von Boehn
(Apollo Team Member)
Posts 4517
11 Feb 2020 18:50


Jonas Thorell wrote:

  I haven't tried with the built-in 
 

 
Vampires are shipped with a very good Kick.
Please use this.
 
I can not recommend to use 3.1.4 Rom
 


Philippe Flype
(Apollo Team Member)
Posts 277
11 Feb 2020 22:15


VControl mr <file> is a 'raw' map rom'ing.
Means the <file> is mapped as is, without any mods. It's nice for example to map emutos or diag roms such as logica, for example.

However, to map kick roms such amigaos ones (eg. 3.1.4 or next to comes), we advise use VampireMap314 which add vampire specific support modules. That's why the DC demo not works because missing vampire.resource.


Jonas Thorell

Posts 7
12 Feb 2020 00:05


Gunnar von Boehn wrote:

Jonas Thorell wrote:

  I haven't tried with the built-in 
 

 
  Vampires are shipped with a very good Kick.
  Please use this.
 
  I can not recommend to use 3.1.4 Rom
 

I have tried the built-in kick, both before and again just now.

So this is getting weird. Or I'm just being stupid.

If I skip softkick and use the built-in kickstart, no "wrong hardware" error. However, when the workbench screen shows up it is the menu bar and a grey  background only that shows up.  No icons, no wallpaper, no nothing. If I comment out end-cli so the shell-window stays, I get an error stating  "Erroneous resident library", but doesn't say which one. It is something loadwb is looking for since I get the same error trying to use loadwb
manually. Vcontrol core still says "Undefined" though and Vcontrol board claims it is a Vampire V500 (but maybe that's normal?) regardless of which Kickstart (built-in or otherwise) I'm using.

I will continue trying to find the problem.


Jonas Thorell

Posts 7
12 Feb 2020 00:10


Philippe Flype wrote:

VControl mr <file> is a 'raw' map rom'ing.
  Means the <file> is mapped as is, without any mods. It's nice for example to map emutos or diag roms such as logica, for example.
 
  However, to map kick roms such amigaos ones (eg. 3.1.4 or next to comes), we advise use VampireMap314 which add vampire specific support modules. That's why the DC demo not works because missing vampire.resource.

Ah, okay. Didn't realize those two worked differently. Makes sense considering that  Vcontrol board warns about missing vampire.resource if using anything else but the built-in kick and vcontrol mr. Apart from the demo, other things written to take advantage of the vampire such as the jpeg-datatype, Riva, and the patched whichamiga are able to use the 68080, but I guess they check for its presence in some other way (or don't need vampire.resource for what they do)

Still, when using VampireMap314 I get an endless reboot-loop instead. Both using my custom kickstart and Hyperions official 3.1.4. Apart from the loop, I guess it is is normal that you get a smaller vampire logo rather than the full-screen one with the vampire girl on the left?

Are there different versions of VampireMap314? So I don't use the wrong one. There is no version string in mine, but its size is 15764.



Philippe Flype
(Apollo Team Member)
Posts 277
12 Feb 2020 04:40


About the loop, i assume you did it in your startup-sequence. Please follow that procedure here,
 
  https://wiki.apollo-accelerators.com/doku.php/system_tools:kickstarts?s[]=vampiremap314#running_a_maprom_program_to_load_the_kickstart_rom_image_from_disk

---
; Kickstart 3.1.4 has expansion.library V45.  For other Kickstarts, use the appropriate version.
Version >NIL: expansion.library 45
If WARN
  ; Use the correct Kickstart file path.  If mapping an extended ROM file with Kickstart 1.3, add the appropriate arguments.
  C:VampireMap314 DEVS:Kickstarts/kick.a1200
EndIf



Philippe Flype
(Apollo Team Member)
Posts 277
12 Feb 2020 04:47


About VControl,

Make sure to usr last one,

https://wiki.apollo-accelerators.com/doku.php/system_tools:vcontrol


Jonas Thorell

Posts 7
12 Feb 2020 22:48


Philippe Flype wrote:

About the loop, i assume you did it in your startup-sequence. Please follow that procedure here,
 

Ah, that did it! Not sure how I could have missed that...I guess the "assumption is mother of all screwups" is the reason. Meaning I  erroneously thought it would detect (as my previous non-vampire softkicker did) it had already been kicked and skip it when necessary.

Still, it works as it should now and vampire.resource is available.

I still get "Undefined" when using vcontrol core (using the latest vcontrol) but that's a minor issue I'm not going to worry about right now.

Now I just need to get on speaking terms with P96Mode...

Thanks for all the help!


Philippe Flype
(Apollo Team Member)
Posts 277
13 Feb 2020 06:38


Glad to help.

The last item, about the 'vcontrol core', that feature isnt avail at moment. Will be later on.

posts 13