Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

Need PINOUT for Ethernetport V500 V2+ Rev2.2

Patrik Rendel

Posts 13
22 Jan 2020 19:00


Hello,
i tried since 2 days to get my ENC28J60 to work with a Vampire 500 V2+ Revision 2.2 but i cant get it to work.

My Ethernetadapter has 3.3V and is an ENC28J60. The 1:1 cable dont work because my adapter has 12 pins and not 10, so i need to set every pin by my own.

The wiki article dont help! There is only the pinout for the old V500 but not the new one.

Can anybody please help me?



Igor Majstorovic
(Apollo Team Member)
Posts 314
22 Jan 2020 19:03


Can you please post picture of your adapter.
But, definitely, I would order adapter we propose, it is very cheap and you can buy it easily.



Patrik Rendel

Posts 13
22 Jan 2020 19:19


Here the photo of my adapter:

EXTERNAL LINK 



Igor Majstorovic
(Apollo Team Member)
Posts 314
22 Jan 2020 19:22


Can't see anything there, only black background.


Patrik Rendel

Posts 13
22 Jan 2020 19:27


Sorry. I hope this one works now.
 
EXTERNAL LINK


Martin White

Posts 82
22 Jan 2020 19:45


The pin out is right there, printed on the module in the picture. And itís says itís a 5v module


Patrik Rendel

Posts 13
22 Jan 2020 19:46


Yes it can be used with both 5V and 3.3V and Q3 means 3.3V



Martin White

Posts 82
22 Jan 2020 19:53


Ah ok. See what you mean now. Given the device on the wiki uses a flat ribbon cable you should be able to see where those 10 pins connect onto your 12 pin device


Patrik Rendel

Posts 13
22 Jan 2020 21:11


This is that what i did and dont work.
 
  where is the problem to say what the pinout is from the new revision and why are there 10 pins if only 7 are in use?
 


Igor Majstorovic
(Apollo Team Member)
Posts 314
22 Jan 2020 21:29


Problem is that you need to wait for someone to reply to you and to resolve problem you have with the device we didn't recommend to use.
I have no idea can that work at all because same chip can be interfaced by number of ways.
 
EDIT: I m trying to make some picture that could help you, pls be patient.
EXTERNAL LINK   


Patrik Rendel

Posts 13
22 Jan 2020 22:31


REALLY BIG THANKS!!!!!!!!!

I got it now to work with your help and the pinout :)
I write this text from my A500 now ;)



Igor Majstorovic
(Apollo Team Member)
Posts 314
22 Jan 2020 22:38


Damn, awesome! Have fun :)

posts 12