Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

Vampire 600 V2 SD Storage

Michael Huck

Posts 17
14 Dec 2019 20:15


Hey all

Can anyone give me any pointers on setting up the micro SD, I want to be able to move files between my Amiga and Mac but so far have only got it working with an Amiga file system which doesnít show up on my mac


Simo Koivukoski
(Apollo Team Member)
Posts 509
14 Dec 2019 20:26


Format your SD card on PC/MAC to FAT32 (0xc) file format in the normal way. Do not use any Amiga tools like HDToolBox, SDMountter or Giggledisk.

Make sure you have:

    DEVS:sagasd.device
    L:fat95
    DEVS:DOSDrivers/SD0
    DEVS:DOSDrivers/SD0.info

And on Startup-Sequence:

    VControl SD=3

Make sure that your DEVS:DOSDrivers/SD0 mountlist uses partition geometry autosense, its content must be like this:

  FileSystem=l:fat95
  Unit=0
  Flags=0
  LowCyl=0
  HighCyl=0
  Surfaces=1
  BlocksPerTrack=1
  BlockSize=512
  Buffers=300
  BufMemType=1
  BootPri=0
  Stacksize=4096
  Priority=5
  GlobVec=-1
  DosType=0x46415401
  Device=sagasd.device




Michael Huck

Posts 17
14 Dec 2019 20:58


Hi Simo

Thanks for answering. I am not an expert and got a bit lost after the instructions to format the micro SD. Iím running coffin os and the things you mention are not in the devs folder. I will have a look on YouTube! Many thanks for taking the time to respond though


Stefano Briccolani

Posts 364
14 Dec 2019 21:08


If you use coffin the only thing to do is to format the SD with Fat32 fylesystem. Then mount it on Amiga clicking the SD mount icon on system folder


Michael Huck

Posts 17
14 Dec 2019 22:05


That didnít work :-(


Roy Gillotti

Posts 357
15 Dec 2019 01:51


Michael Huck wrote:

  That didnít work :-(
 

  having similar issues, for some reason on my Mac if I try to format it to fat it doesn't see it... I throw it in my Linux box, format it to fat32 and it works fine.
 
 


Michael Huck

Posts 17
15 Dec 2019 10:12


I tried that and formatted the disk in parralels desktop as Fat 32, plugged it in the vampire and bingo, it worked straight away! Thank you

posts 7