Overview Features Coding ApolloOS Performance Forum Downloads Products Order Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
Please visit our Apollo-Discord Server for support.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Running Games and Apps.

Land of Genesis

Kristof C.

Posts 52
15 Sep 2023 09:32


Hat jemand das Spiel schon erfolgreich zum laufen bekommen? Bei mir stürzt das System nach dem Intro im Menu ab und das System startet neu. Mit einem Update des Spiels kam ich auch nicht weiter.


Gunnar von Boehn
(Apollo Team Member)
Posts 6196
15 Sep 2023 12:36


Kristof C. wrote:

Hat jemand das Spiel schon erfolgreich zum laufen bekommen? Bei mir stürzt das System nach dem Intro im Menu ab und das System startet neu. Mit einem Update des Spiels kam ich auch nicht weiter.

 
Hallo Kristof,
 
Ich kenne das Spiel nicht.
Kannst Du mal etwas mehr Informationen geben?
 
0) Welches OS benutzt Du?
 
1) Wie startest Du das Spiel laufen?
  WHDLOAD?
  Von Floppy?
  Von ISO?
  Von HD-install?
 
2) Das Spiel is AGA?
  Benutzt Du deine Karte im 6MB Chipmem mode?
 
3) Ist deine WB auf RTG oder PAL?
 
4) Hast Du turtle-game mode für das Spiel aktiviert?
 
5) Hast Du Netzwerk an/aus?
  ein aktivierter Netzwerk stack kann vielen Spielen Probleme machen.
 
Welcher Fehler kommt genau?


Henrich Raduska

Posts 62
15 Sep 2023 14:20


EXTERNAL LINK    Req. For basic version:
  * 68020 CPU or faster
  * 2Mb Chip RAM
  * 2Mb Fast RAM
  * 11Mb hard disk space
 
  Req. For extended version:
  * 68040 CPU or faster
  * 2Mb Chip RAM
  * 3Mb Fast RAM
  * 8Mb Fast RAM to watch full animation
  * 11Mb hard disk space required
  * 70Mb hard disk space optional
 
  Basic version includes:
  * 3D movie
  * 5 levels of platform/shoot'em up
  * 180 enemies
  * 12 audio tracks
 
  Extended version includes:
  * 512 colours on screen
  * Transparency
  * 12 extra backgrounds
  * Extra parallax
  * Enemies with artificial intelligence
 
  This game crashed WinUAE 1.2.0 (the actual emulator, not just the Amiga it emulates ). It worked fine using WinUAE 2.8.1, 0.9.92 though.


Kristof C.

Posts 52
15 Sep 2023 17:43


Ich benutze Coffin R62.
Die 6MB ChipRAM sind aktiviert.
Turtle Mode habe ich nicht geändert.
Netzwerk ist in der Tat ein Problem bei WHDLOAD, das ist aber bekannt. Coffin macht das bisher ziemlich gut und schaltet das Netzwerk automatisch aus.
Land of Genesis ist kein WHDLOAD Spiel sondern ein Titel für AGA Amigas auf CD.

Eine Fehlermeldung bekomme ich nicht. Der Rechner stürzt ab (ohne Guru Meldung) und startet dann neu.


Tim Waite

Posts 42
15 Sep 2023 18:22


Make sure you have the latest patch for the game "Land.of.Genesis.Fix.v1_0gt+Trainer.zip"

Check out the website EXTERNAL LINK


Kristof C.

Posts 52
15 Sep 2023 21:38


Danke für den Tipp!

Den Patch habe ich installiert. Problem bleibt bestehen.


Tim Waite

Posts 42
15 Sep 2023 23:11


On ABIME they have a thread that talks about this game and a suggested start script.  One thing they do is set the stack to 1000 before they run gencli.
 
  Read here: EXTERNAL LINK 
  They even talk about a fix to the V1.0GT in "Land_of_Genesis_v1.0GT_fixes.zip" in the thread.
 
  There also might be issues with the CDDA audio since you I doubt you have a CD-ROM drive or ISO image mounted.
 
  Hope this helps.
 


Gunnar von Boehn
(Apollo Team Member)
Posts 6196
16 Sep 2023 08:14


Kristof C. wrote:

Netzwerk ist in der Tat ein Problem bei WHDLOAD, das ist aber bekannt. Coffin macht das bisher ziemlich gut und schaltet das Netzwerk automatisch aus.
Land of Genesis ist kein WHDLOAD Spiel sondern ein Titel für AGA Amigas auf CD.

 
Hast Du das Netzwerk abgeschaltet?
Nicht nur WHDLOAD hat Probleme mit Netzwerk - das ist ein allgemeines Problem.
 
Beim Amiga funktioniert das so: Die Amiga hardware läuft parallel zur CPU, d.h. die Netwerkkarte kann Daten Empfangen und gibt der CPU dann bescheid "mit IRQ" das ein Paket empfangen wurde.
Wenn die Netzwerk läuft und Du ein Spiel startest - welches vielleicht das OS ausknipst ... aber evtl die Netzwerkkarte anlässt - dann lauscht die Netzwerkkarte in deinem Netz und "sagt irgendwann" der CPU bescheid - guck mal nach da ist ein Paket für uns angekommen ... Das Spiel rechnet damit nicht und könnte damit vermutlich nicht umgehen.
 
Hast Du mal in CLI gebootet ohne Startup-sequence und Spiel vom CLI gestartet?


Kristof C.

Posts 52
16 Sep 2023 09:08


Achso, ja, das Netzwerk war abgeschaltet.
Werde es auch mal ohne Startup-Sequence ausprobieren.

posts 9