Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Running Games and Apps.

Quake 1 Won't Load Savegame Files

Bart Mikulski

Posts 100
08 May 2018 17:45


Gold 2.9, Vampire 600 V2, Coffin r51/ Classic WB 3.9

I mentioned this problem before in my larger post, but I'm posting this specific one hoping it's solvable.

So, Quake (the one supplied with Coffin) runs, I am able to save, and even load a savegame file once or twice (usually first and/or second save), but after 2-3 times it is possible to save but not possible to load anymore (and not possible when I restart the game). It hangs on "loading" for about a minute and the I get these types of messages:

EXTERNAL LINK 
I tried it on 2 different CF cards, 2 different systems, it's exactly the same. I also tried running it through SamQuake file, no difference.

Another version of Amiga Quake I found, loads and saves ok, but freezes while finishing first level, so I still can't play. I have no problems with that with other games.

Any ideas how I could fix it? Thanks.



Samuel Devulder

Posts 246
10 May 2018 21:36


I think it is my gcc2.95.3 version of february which is shipped.

I still work on it and tried it yesterday on a plain 1200 + blizzard 12030-iv. I tested save/load many times and could'nt find an issue :-/ May be it is a vampire specific issue, or it is a bug that has been fixed. I'll try it ASAP on my (awaited) vamp to figure out the problem.

Thank you for reporting.


Bart Mikulski

Posts 100
19 May 2018 11:34


Samuel Devulder wrote:

I think it is my gcc2.95.3 version of february which is shipped.
 
  I still work on it and tried it yesterday on a plain 1200 + blizzard 12030-iv. I tested save/load many times and could'nt find an issue :-/ May be it is a vampire specific issue, or it is a bug that has been fixed. I'll try it ASAP on my (awaited) vamp to figure out the problem.
 
  Thank you for reporting.

Thank you for showing interest in the problem.

Could you please post a link to the gamefiles? I'd like to reinstall the files and try it again.

posts 3