Overview Features Instructions Performance Forum Downloads Products Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireCoffinReleases
Performance and Benchmark Results!

VCONTROL Maprom Corrupt KS Screen

Tim Kovack

Posts 36
30 Mar 2018 05:42


Anyone have this issue?  Tried all kinds of KS 1.x roms, all the same.  Works but not many games work, to fast I guess!

EXTERNAL LINK


Sean Sk

Posts 125
30 Mar 2018 07:34


Yeah I get that graphics corruption as well. Don't know what causes it though.

I find game compatibility a bit hit n' miss with it, some work, some don't, sometimes due to bad or lazy game programming. If you find games running too fast you can try activating turtle mode by typing "tu 1" in your vcontrol line when you maprom a kickstart rom and see if it helps.


Philippe Flype

Posts 190
30 Mar 2018 07:42


Did not noticed this corruption,

You could try VControl VS 1 MR kick11.rom

VS for VideoSleep, to DMA off the DIGITAL-VIDEO output.
KICK 1.1 because this kick does not know about 68040 so it see us as a 020 and so that it tries enable Cache for 020 which have different CACR design and actually disable cache on a 040 (and so 080).


Martin Soerensen

Posts 198
30 Mar 2018 10:18


You get the same graphic corruption if you load KS1.3 on a plain A1200 (for example using skick), so perhaps it just has to do with the CPU being faster than ~7MHz and thus maybe generating some errors in decrunching the image.


Istvan Hegedus

Posts 5
25 May 2018 17:09


You can see the same in WinUAE as well if you configure a 68040 CPU. I believe the reason is that KS 1.1-1.3 was written for 68000 CPUs. I don't remember whether I tested it with 68020 or 68030 CPUs but my conclusion was that it requires 68000.

posts 5