Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Questions and Answers for AROS AMIGA OS

New Version of Aros Vision for Vampire In Developmpage  1 2 3 

J.M. Lapilainen

Posts 21
11 May 2020 16:20


Ah, I haven't updated to the latest yet, running 2.11 still. I'll see if latest core solves it.


Olaf Schoenweiss

Posts 652
11 May 2020 18:30


I was just informed that it also works on V4


Olaf Schoenweiss

Posts 652
12 May 2020 22:27


new version of Base version
 
  EXTERNAL LINK 
  new version of full version (more software included)
 
  EXTERNAL LINK 
  both should work on V2 and V4

diskimagedevice works so you easily mount adf (rightclick on adf file)
 
  main difference is volume of software included


Adam A

Posts 106
12 May 2020 23:03


Great news, one problem

The second link does not work for me


Olaf Schoenweiss

Posts 652
12 May 2020 23:33


you were right

now it works


Bill Panagouleas

Posts 28
13 May 2020 03:50


Nice news, thanx.


J.M. Lapilainen

Posts 21
13 May 2020 05:29


Issues I've noticed so far:

- Joystick button does not work with at least Cave Story, HCL and Tiny Little Slug. Button does work with WHDLoad in AROS and with Cave Story on  my 3.1 install so should not be hardware issue. These games use SDL for input?
- On boot, something blocks the shell window from closing so when screenmode changes I get Intuition system request -> need to close shell and click retry. This is inconvenient on V2 as I need to switch display input to RGB to do that and then switch back to DIGITAL-VIDEO.
- Included DevilutionX with Shareware data works in AROS. I have DevilutionX with full game data on my SD-card which works on my 3.1 install but it does not even start in AROS.
- Not sure about this one but I think the name/label of my SD-card has first two characters swapped in AROS. Will confirm later.
- Full version does not boot properly on V2, at least on my system. Ramlib(?) crashes and I get guru on reboot.

I quickly tested all WHDLoad games that come with base version (minus the one that requires AGA) and they seem to work as expected. More later.


Olaf Schoenweiss

Posts 652
13 May 2020 21:23


thanks for first report


Gunnar von Boehn
(Apollo Team Member)
Posts 4896
14 May 2020 06:40


J.M. Lapilainen wrote:

Issues I've noticed so far:
 
  - Joystick button does not work with at least Cave Story, HCL and Tiny Little Slug.

This Firebutton not working is a Bug in AROS Lowlevel Lib.
We fixed this some time ago.


J.M. Lapilainen

Posts 21
14 May 2020 12:39


J.M. Lapilainen wrote:

  - Included DevilutionX with Shareware data works in AROS. I have DevilutionX with full game data on my SD-card which works on my 3.1 install but it does not even start in AROS.
  - Not sure about this one but I think the name/label of my SD-card has first two characters swapped in AROS. Will confirm later.
 

  Apparently SD-card is mounted read-only (FATFileSystem does not support R/W?) so I'm guessing that might be the issue with DevilutionX in this case. I use fat95 on my 3.1 install and I tried to use it in AROS in place of FatFileSystem but that causes whole system to freeze when trying to mount SD-card.
 
  I also checked that SD-card label issue and yeah, it's different between 3.1 and AROS: in 3.1 it's name is 8F99-4D5D, in AROS it's F899-D4D5. I suppose these are more of AROS issues than AROS Vision though.


Olaf Schoenweiss

Posts 652
14 May 2020 20:31


could you try L:fat-handler?


J.M. Lapilainen

Posts 21
16 May 2020 01:51


With fat-handler, it doesn't crash but unfortunately sd-card is not mounted either.
 
  I tried to play that MPG in test files, doesn't work. When I double click it, screenmode changes to a lower resolution, and then back to normal almost immediately and nothing happens. Right click -> Play with Riva 080 also does nothing.
 
  MP3 in test files plays. I also tried some of my own, those play slower than they should. Flacs sort of play with ffplay, it's just too slow so its constantly skipping. Tried to test with AmigaAMP3 while I was at it. Trying to move its skinned window is a slide show, playlist buttons do not work and trying to open an MP3 crashed the whole system.
 
  I also tried more WHDLoad games. Almost all worked flawlessly and only 2 out of maybe 15 games I tested didn't. I also tested pokemon silver with gnuboy and it ran but colors were completely off. I tried A/NES too, but it crashes the moment I click Volumes or Parent on file requester. I'll test some other emulators and another bunch of WHDLoad games next.
 
  I've done some (very, very) basic usage like going through Prefs and basic file management. In such use things mostly work. There are some minor cosmetic issues/graphical glitches here and there but nothing big. AROS crashes a lot more than 3.1 on my machine, and most of the time it seems to happen when copying files from ram disk or SD-card to CF-card. Can't say for sure it's not a hardware problem but the difference in stability is very obvious. I'll try to find some time to recap my 500 and maybe get a new CF-card, see if it changes anything.


Gunnar von Boehn
(Apollo Team Member)
Posts 4896
16 May 2020 06:46


J.M. Lapilainen wrote:

MP3 in test files plays. I also tried some of my own, those play slower than they should.

I assume the reason is that default AMIGA audio can max play 28Khz, not 44KHz of most Mp3.

posts 53page  1 2 3