Overview Features Instructions Performance Forum Downloads Products Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesApolloVampireReleases
The team will post updates and news here

Vampire 2, #1?page  1 2 3 

Wawa T

Posts 400
18 Apr 2017 15:51


sounds like the ide (ata) driver issue i was talking about. i dont think that much changed in respect to wanderer though.


Nick Fellows
(Apollo Team Member)
Posts 20
18 Apr 2017 15:59


I would like to suggest something that I personally was dissapointed at not being present in the Amiga from the outset.
SID ! How about including options for a socketed SID or even one of the clones such as SwinSID. would there be room to have that on the FPGA even? This would be a big selling point for Old Skool / Chiptune musicians.


Gunnar von Boehn
(Apollo Team Member)
Posts 2845
18 Apr 2017 17:04


nick fellows wrote:

I would like to suggest something that I personally was dissapointed at not being present in the Amiga from the outset.  SID !

I understand you, SID was cool.
To be honest I was always a big SID fan myself.
Also did a SID in FGA long time ago, must still have it somewhere.

While I have the SID chipset and would feel proud to put it in the FPGA - I have to say I'm not 100% certain this is the best usage of the FPGA. Maybe it would be of more value to use the FPGA space for something else as the SID could today easily also be done with the CPU.


Nixus Minimax

Posts 181
18 Apr 2017 17:12


wawa t wrote:

sounds like the ide (ata) driver issue i was talking about.

Yes, this problem still exists. Some work has been done on making AROS boot on Vampire (or rather fixing AROS' IDE functionality) but I have no idea how quickly we may expect this to succeed.



Wawa T

Posts 400
18 Apr 2017 20:41


Nixus Minimax wrote:

 
wawa t wrote:

    sounds like the ide (ata) driver issue i was talking about.

   
    Yes, this problem still exists. Some work has been done on making AROS boot on Vampire (or rather fixing AROS' IDE functionality) but I have no idea how quickly we may expect this to succeed.
   
 

 
  what kind of work? i have been trying to trace this bug down with the help of toni, but with no results, since it exists also on a4000 internal port.
 
  it would be best to share the experience and the sources and work together on this, rather than everybody trying to solve it for themselves. im not a coder, especially not a hardware driver expert, but as far as i remeber the problem is bound to minimalistic hardware that serves on amiga for ide interface. it was either timing, interrupt, or some missing termination (maybe a left out resistor on the bus or something), that the ide either doesnt work or rather aros doesnt recognize it as working and hangs there waiting for a feedback forever.
 
  funny thing is, that if you wait long enough, for ages actually, it may even boot through, so i think the problem is definitely within reach.
 
  edit: just an idea, but with the current dma additions to the core, especially the a600 ide boost, does the problem still even exists? someone tried it lately? how does it behave with a500? did anybody tried aros68k on it?


Michael R

Posts 232
18 Apr 2017 20:44


Nixus Minimax wrote:

 
wawa t wrote:

    sounds like the ide (ata) driver issue i was talking about.

   
    Yes, this problem still exists. Some work has been done on making AROS boot on Vampire (or rather fixing AROS' IDE functionality) but I have no idea how quickly we may expect this to succeed.
   
 

 
  Is this a good time for an AROS monetary Bounty to revise the AROS IDE so that the 68k version(s) of AROS boot up and run on Vampires? And in the process it may solve issues with the A4000 IDE as well.
 
  Many people on this forum and maybe elsewhere would gladly contribute for a worthy cause like this. Just post the link for us.
 


Wawa T

Posts 400
18 Apr 2017 20:51


i dont think we need money. we need coders and testers to look into it. i dont have vampire unfortunatelly, but i do have the same problem with a4000 (currently not with me). even if i cant solve this i can compile and check tests and proposed solutions. best thing would be to open a public thread about it on eab, because toni reads there, and if we just do it per mail, none else who might can contribute.


Thierry Atheist

Posts 465
27 Apr 2017 10:46


! ! GOOD NEWS ! !

More and more fine upstanding people are getting fanged by the Vampire!

Here's one such person.

EXTERNAL LINK 
While it's "one person", he at the moment represents probably 5% of the extreme coders that are getting back to the roots. :-DDD

Soon, it will be an epidemic!

I hope to get people like Dave Haynie and François Lionet "back in" too....

The tombstones* are falling...... ;-)

Just maybe, you're next? :-o

( * For the sensitive, substitute "dominoes".)


Michael R

Posts 232
27 Apr 2017 15:06


Good news whenever anyone comes back.

I prefer Dominoes! I've already been to Tombstone (Arizona). Nothing like Boot Hill.

I read a tombstone there..."Here lies Lester Moore. Took 2 slugs from a 44. No Les no more!"

More like pieces of the puzzle falling into place. I might be one of those soon to be Amiga novice coders! It's good to have professional coders to ask questions.

I would sure would like PCI express for Amiga to give us something to really code for. Oh well, just wait a while...


Pedro Cotter

Posts 40
27 Apr 2017 15:56


one thing's for sure: the Vampire is reawakening a lot of people and put to tremble the 68K world.



Obetto Sannala

Posts 43
28 Apr 2017 09:30


...like me... :-)


Michael R

Posts 232
28 Apr 2017 20:07


Obetto Sannala wrote:

...like me... :-)

For all those fortunate people who are returning to Amiga after being away for many years...welcome back! These are exciting times!

posts 52page  1 2 3