Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
The team will post updates and news here

First (joyful) Impressions of My A34 V4

Tim D

Posts 55
13 Oct 2019 19:45


Yesterday I was one of the happy few getting a Vampire V4 Standalone!! Today I did a short first test run.

I must say this is really a cool product! I have it running Coffin R55 and basically it's ready out of the box. It comes with all you (well at least I) need.

Luckily I can route audio out of my monitor so the DIGITAL-VIDEO audio ends up on my speakers in the end. Of course it's clear this thing is only at the beginning of its lifecycle and I hope for much development to make it even better!! I also still have a few questions.

- Is it correct that for now the DB9 connectors only work with joysticks and not with an Amiga mouse? When I plug in an Amiga mouse I see the pointer shake a tiny when moving the mouse, but I can't drag it around the screen. The provided USB mouse works all fine though.
- Are the USB ports dedicated for the mouse and keyboard, or can you switch those around? I really hope in the future it will be possible to connect one Logitech unify to one USB port for both (native Amiga, not USB Poseidon) mouse & keyboard. And hopefully the second USB can then be exposed to the AmigaOS as USB device managed with Poseidon. Since the nice RGB keyboard that came with the Vampire is QWERTZ I will in the end not use it, so I do hope for Logitech Unify support soon :)
- Are there options that allow me to get wifi via JTAG working? My network switch is full (I know ethernet is not ready yet) :)
- Is there, or will there be instructions available soon to load different roms? Hopefully we can also get a downloadable AROS image like Coffin from somewhere, as I would really like to try that as well.




Klaus Melchert

Posts 7
13 Oct 2019 19:53


I also bought the v4 sa in Neuss - have installed coffin os 54 but  problems - where did you get coffin R55 ?


Tim D

Posts 55
13 Oct 2019 19:58


It came with my V4.

I do experience some games that don't have audio.
And is there already a way to make use of / test the advanced Pamela capabilities?


Martin Conley

Posts 6
13 Oct 2019 20:12


"Is it correct that for now the DB9 connectors only work with joysticks and not with an Amiga mouse? When I plug in an Amiga mouse I see the pointer shake a tiny when moving the mouse, but I can't drag it around the screen. The provided USB mouse works all fine though."
 
  from what I was told. As I managed to get one too, that the mouse and comm next to it share. but im still in germany and don't go back till tomorrow.
 
 
  "- Are there options that allow me to get wifi via JTAG working? My network switch is full (I know ethernet is not ready yet) :)"
 
  There is something wifi wise they mentioned.
 
  "- Is there, or will there be instructions available soon to load different roms? Hopefully we can also get a downloadable AROS image like Coffin from somewhere, as I would really like to try that as well."
 
  I ask this and I was told the 3.1 on the board is patched to allow the 11mb chip ram so don't know if we can just put on another rom keeping that or loose it back to 2mb. as I would love to go 3.1.4 but I won't mess till told.
 
 


Mike Kopack

Posts 261
13 Oct 2019 20:46


The USB right now is dedicated for KB and Mouse. they aren't "full on" USB ports where you can plug anything you want in.

Don't know about using Amiga mouse, I would assume no for now based on what you experienced.

There will be info coming on how to load 3.1.4 or 3.1 ROMs. It's probably similar to how it's done for the V500/600 models (see here: EXTERNAL LINK  but that's just a guess.

Wifi - I've had lots of discussions with the team about this. They believe it will be possible to wire up a ESP32 module to the expansion ports, but a driver will need to be written for it to work, and that hasn't been done yet. So for the near future the answer is no.

I expect information will get posted by the team in the next few days after they get back from the show...

In the mean time, enjoy what you have you lucky bums!!!!


Oliver Urbann

Posts 3
13 Oct 2019 20:59


Are your boards stable so far? I already got some help in IRC (thx, helped a lot, it now boots reliably) but the shipped mouse keeps failing: no light on mouse or similar within minutes but the system sometimes still works. Plugging out and in again reactivates the mouse sometimes. I'm currently not sure if this also happened with the shipped core as it booted to rarely.
 
  Additionally, moving a window (e.g. workbench directory window) can cause a freeze within seconds. This also happened with the shipped core. It does never happen when I play one of the videos. So it must be something related to a movement and not just a screen update. Probably this is the same problem as above as such a freeze usually also comes with a failing mouse.
 
  I ask because maybe the mouse is not optimal for the board but I tried all mice I have and none is supported, so I cannot test this.
 
 


Jens Künzer
(Apollo Team Member)
Posts 39
15 Oct 2019 01:17


The Amiga mouse support is disabled at the moment.
Long Story: It was implemented, but caused problem on one early developer board. Except for two player Lemmings I don't know any application using it. So it was disabled, but there is a good change that Amiga mouse will be supported again in not too far future.

USB ports are dedicated (for now, but there are plans to improve USB we will see ...)



Tim D

Posts 55
15 Oct 2019 07:40


Great to hear! I understand that extending the USB capabilities is not top priority, but I really hope it eventually will happen. I'dd love to connect the Vampire to my USB ("KVM"-like) switch which has a logitech unify so I can use one keyboard and mouse for multiple systems.


Michal Pietal

Posts 89
16 Oct 2019 20:13


My V4SA was also bought in Neuss, by a fellow Amigan who actually was there.

Should arrive on Friday or Monday.

Will post my impressions here as well.


Wawa T

Posts 690
17 Oct 2019 00:39


@tim
    i case ou missed it on another thread here is what ive posted bout aros ks and images elsewhere:
 
    im not sure in what form and shape you need the aros roms, but their latest compiles can be downloaded here:
    EXTERNAL LINK  navigate to the subdir with the latest datum and choose your preffered archive format.
    the files contain a whole aros installation. but the roms are in boot/amiga: aros-rom.bin and aros-ext.bin.
   
    alternatively
   
    EXTERNAL LINK has
    amiga-m68k-boot-floppy.lha which contains compressed adf, so maybe thats too complicated. also there
    amiga-m68k-boot-iso - contains iso and the roms are again in boot/amiga dir.
   


Oliver Urbann

Posts 3
17 Oct 2019 14:24


My V4SA crashes within a few minutes, so I'm sure stability is the top priority for most users. Or is it just my card?


Ronnie Beck
(Apollo Team Member)
Posts 138
17 Oct 2019 15:01


Oliver Urbann wrote:

My V4SA crashes within a few minutes, so I'm sure stability is the top priority for most users. Or is it just my card?

What do you mean exactly by "crashes within a few minutes"?  A few minutes of what?  Booting?  Running a specific game/demo/application?  What do you mean by crash exactly? Do you get a GURU or does it just freeze?

What version of WB are you using?  Did you install the 1.6 SAGA drivers?  Does it only happen when using RTG or is there a problem with AGA screen modes as well.

My V4 is very stable or at least it doesn't crash/freeze every few minutes.


Oliver Urbann

Posts 3
17 Oct 2019 15:19


I have a description of my problem above.
     
      Crashing means freezing with a freezed image on monitor or monitor does not get a signal anymore. I'm using coffin 55 as shipped on A34. I tried different RTG resolutions and pixel frequencies.
 
  It it helps I could make a video.
 
  Update: Often it does not even boot (freezing image or signal lost at random point in boot process).

posts 13