Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
The team will post updates and news here

GOLD2.12 Release Candidatepage  1 2 3 4 5 6 7 8 9 10 11 12 

Lord A1k

Posts 46
19 Aug 2019 09:32


ok possible 2.11 was already there, I usually use "Fusion", so maybe I did not notice


Simo Koivukoski
(Apollo Team Member)
Posts 587
19 Aug 2019 09:34


It would be helpful if you can find the exact core rev, where Wolfenstein3D issues started.


Michael AMike

Posts 140
19 Aug 2019 09:39


Can I flash back to 2.9 with the existing software setup or are there any pitfalls?


Simo Koivukoski
(Apollo Team Member)
Posts 587
19 Aug 2019 10:15


Should work, if you set software mouse pointer for RTG. Can't remember off the top of my head when FEMU is needed instead of HW FPU.


Michael AMike

Posts 140
19 Aug 2019 10:26


Where can I set the software mouse pointer? Thank you


Simo Koivukoski
(Apollo Team Member)
Posts 587
19 Aug 2019 10:38


SoftSprite=Yes from the monitor icon tooltypes.

And put the memory size back to VideoMemSize=8M or similar.

( in DEVS:Monitors/ -folder )


Michael AMike

Posts 140
19 Aug 2019 11:40


Thanks Simo - will try some older cores.


Simo Koivukoski
(Apollo Team Member)
Posts 587
19 Aug 2019 14:25


Chris T. wrote:
1. Full support of Native HD Games install (Fate Gates of Dawn does not work e.g.)
2. Maprom Function: SWIV is still not working.
Secondly it should work with A500 Rev.6 boards plus chipram mod (1MB) and Ranger Mem 1.5 MB

Should they work with A500 Rev.6 boards plus chipram mod (1MB) and Ranger Mem 1.5 MB and a very fast 040 CPU?
 
Have you tested WHDLoad version of them? WHDLoad slaves have often 040 fixes to make old games/demos to work with newer CPUs than 68000.
 


Michael AMike

Posts 140
20 Aug 2019 06:16


Didn't have time for testing yet, but I looked at a1k bord when I first reported the problem. It came with the 2.7 core. But I will thest with the 2.5 core to be on the safe side.
Original
https://www.a1k.org/forum/index.php?threads/53941/page-99#post-1168544

Yesterday I completely reinstalled P96 and SAGA as described in the wiki. But that dosen't help.


Michael AMike

Posts 140
20 Aug 2019 20:27


I just installed the 2.5 core. Unfortunately P96 doesn't work anymore, all SAGA screencs are gone. Any hint? Thanks


Simo Koivukoski
(Apollo Team Member)
Posts 587
21 Aug 2019 08:20


Thanks for your effort! Basically Gold2.0 and 2.5 are the same core, but 2.5 has an updated kickrom. Did you test oldest RTG driver? https://wiki.apollo-accelerators.com/doku.php?id=start#latest_drivers


Michael AMike

Posts 140
21 Aug 2019 14:22


The SAGA drivers are according to wiki from 2018 the 2.5 core is from 2017.. Which of the old gfx drivers should I test im comb. with 2.5?  Is it enough to change the vampiregfx.card or a complete reinstall?


Simo Koivukoski
(Apollo Team Member)
Posts 587
21 Aug 2019 14:49


Changing vampiregfx.card is enough, just backup current one first. If you get RTG, it's good enough for the quick tests. Try with oldest one first. If they was named as saga.card, you need to update that driver name to the monitor icon tooltype, Boardtype=saga.


Simo Koivukoski
(Apollo Team Member)
Posts 587
26 Aug 2019 13:24


Michael AMike wrote:

No,same problem with 2.11. I can't remember exactly - I think the GFX issues came with 2.9 or 2.10. Marathon Infinity has also heavy glitches. Doom II and Duke3d are working.

To isolate the issue, could you please test if this helps for the glitches when using latest RC core and drivers:

<wasnotthis>


Michael AMike

Posts 140
26 Aug 2019 13:41


Hello, Simo,
thanks for the foolproof instructions - i will test asap. The weather was too nice the last days for further tests. :)


Michael AMike

Posts 140
27 Aug 2019 09:42


Im made a quick test yesterday - but with this command Shapeshifter gets stuck while booting.  When I have time I'll post my Startup Sequence - I use an old CoffeinOS installation and there are commands I can't interpret. Maybe this is the reason.


Simo Koivukoski
(Apollo Team Member)
Posts 587
27 Aug 2019 12:53


Michael AMike wrote:

Im made a quick test yesterday - but with this command Shapeshifter gets stuck while booting.  When I have time I'll post my Startup Sequence - I use an old CoffeinOS installation and there are commands I can't interpret. Maybe this is the reason.

Probably your MAC OS installation didn't like it. Here's yet another debug prg to test: EXTERNAL LINK


Michael AMike

Posts 140
27 Aug 2019 13:35


That was fast :) Will test - thanks.


Chris Edwards

Posts 43
27 Aug 2019 18:01


thought it was supposed to use the 1200 rom . ?


Michael AMike

Posts 140
27 Aug 2019 22:30


Wohoo - that file fixes the bug. Wolfenstein and Marathon Infinty are now working without any GFX glitches. Great - thanks. What was the problem?

posts 236page  1 2 3 4 5 6 7 8 9 10 11 12