Overview Features Instructions Performance Forum Downloads Products Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireCoffinReleases
The team will post updates and news here

Vampire V2 Is Now AmigaOS 3.1.4 Readypage  1 2 3 4 5 

Renaud Schweingruber

Posts 250
29 Sep 2018 18:02


Thanks to the awesome work of Bax, all Vampire V2 are now ready for AmigaOS 3.1.4
 
All instructions available on our Wiki
EXTERNAL LINK 
 
Ready for landing !


Andrew Miller

Posts 150
29 Sep 2018 18:10


Nice, didnt even know it had been released. Going to see if I can get a copy now :) Will be handy once I get colour on my Vampire :)

Edit: anyone know where you can get it?


Vojin Vidanovic

Posts 736
29 Sep 2018 20:27


Its nice mapROM and FlashROM option exist for latest real Kickstart.
  Does it have any real benefits over VampROM beside being able to kick OS 3.1.4 (whatever that will be. And in the end, does OS 3.1.4 make any sense compared to OS 3.9BB3+ I intend to use?


Gregthe Canuck

Posts 270
29 Sep 2018 20:47



Thanks Bax!!


Sean Sk

Posts 189
30 Sep 2018 05:27


Vojin Vidanovic wrote:

And in the end, does OS 3.1.4 make any sense compared to OS 3.9BB3+

 
Well for starters, if it sells well, OS 3.1 will see further active development whereas OS 3.9 will not due to some sources being lost and messy licensing. Plus this will give people an opportunity to financially support development of an Amiga operating system that could eventually surpass OS 3.9.

Anyway an installer has been made that will update OS 3.5/3.9 with OS 3.1.4 components. EXTERNAL LINK 

I personally don't own OS 3.9 and am not interested in buying it if it is no longer being developed anymore. I own a license for 3.1 and intend to buy 3.1.4.


Tim Trepanier

Posts 37
30 Sep 2018 06:29


Vojin Vidanovic wrote:

And in the end, does OS 3.1.4 make any sense compared to OS 3.9BB3+ I intend to use?

I see two more big reasons.
1. Support for >4BG hard drives throughout the OS. Instead of using a small Amiga partition to reboot your system into a foreign filesystem on a larger partition you can format your larger then 4GB HD with the native Amiga file system and boot right from it. This >4GB support is extended to all applicable AmigaDOS commands and utilities including HDToolBox.

2. Bug fixes throughout the entire system. Anything that makes AmigaOS more stable has to be a good thing.



Vojin Vidanovic

Posts 736
30 Sep 2018 06:46


sean sk wrote:

  Anyway an installer has been made that will update OS 3.5/3.9 with OS 3.1.4 components. EXTERNAL LINK 

OS 3.9 is unofficially updated - see BB4 and Coffin.

So, yes it brings new KS and can update OS 3.9
That are good enough reasons to buy it.

Price and availability?


Thomas Blatt

Posts 123
30 Sep 2018 06:54


Well done guys, i will buy it


Sean Sk

Posts 189
30 Sep 2018 07:50


This is excellent news, thanks for sharing the info Renaud!

Is there any chance that Apollo Accelerators will obtain a license agreement with Hyperion to permanently include the 3.1.4 ROM (or essential elements of it) in the core?
 
Depending on what happens with Gold 2.11 and Gold 3, I could potentially see myself swapping between the cores on a reasonably regular basis depending on what I felt like doing with my Amiga 600 at that particular time. Having to re-flash the ROM each time could be a little painful, or would mapROM'ing 3.1.4 be better?


Vojin Vidanovic

Posts 736
30 Sep 2018 11:12


sean sk wrote:

  This is excellent news, thanks for sharing the info Renaud!
 
  Is there any chance that Apollo Accelerators will obtain a license agreement with Hyperion to permanently include the 3.1.4 ROM (or essential elements of it) in the core?
 

 
  No need, mapROM feature is ment to be used to "hotswap" CBM KS 1.2, , CBM KS CD32, Remus Made Escom+ KS 3.9, CBM KS 3.1,Cloanto KS 3.1, Hyperion KS 3.1, Hyperion KS 3.1.4, VammpireROM,AROS Kickstart, AtariTOS ... you name it baby, as long it is 68k and knows a bit about Amiga or Vampire.


Niclas A
(Apollo Team Member)
Posts 183
30 Sep 2018 12:18


Vojin Vidanovic wrote:

sean sk wrote:

  This is excellent news, thanks for sharing the info Renaud!
   
    Is there any chance that Apollo Accelerators will obtain a license agreement with Hyperion to permanently include the 3.1.4 ROM (or essential elements of it) in the core?
 

 
  No need, mapROM feature is ment to be used to "hotswap" CBM KS 1.2, , CBM KS CD32, Remus Made Escom+ KS 3.9, CBM KS 3.1,Cloanto KS 3.1, Hyperion KS 3.1, Hyperion KS 3.1.4, VammpireROM,AROS Kickstart, AtariTOS ... you name it baby, as long it is 68k and knows a bit about Amiga or Vampire.

Would be nice to include 3.1.4 in Vampire 4 instead of 3.1 maybe. but if the team already have a nice deal with 3.1 roms then better leave it to the user.



Vojin Vidanovic

Posts 736
30 Sep 2018 12:24


Niclas A wrote:

    Would be nice to include 3.1.4 in Vampire 4 instead of 3.1 maybe. but if the team already have a nice deal with 3.1 roms then better leave it to the user.
 

 
  I would expect Vamp ROM to improve on its own using OS 3.9/AROS//EmuTOS/MacClassic ROMs as basis and without 512KB limit. Real usable Kickstart in ROM, what NGs can only dream of. You cant have it all, at least not in Amiga World.
 
  However, where is that OS 3.1.x avail?
 
  I see no trace of it on "1st Amiga choice" nor Hype website mentiones it (even I see long rant how good Hype is and how bad Cloanto must be).
 
  But I do see ReloKick 1.3, could that be pre-purchased and installed in VampROM for easy A500 downgrade?). Could be licensed from "evil" Cloanto, if useful at all.
  EXTERNAL LINK


Peter Heginbotham

Posts 156
30 Sep 2018 14:18


Renaud Schweingruber wrote:

Thanks to the awesome work of Bax, all Vampire V2 are now ready for AmigaOS 3.1.4
 
  All instructions available on our Wiki
  EXTERNAL LINK 
 
  Ready for landing !

How does effect the extend rom modules in the vampire rom and are these to be avalible.

(from gold 2.8)
fpsp080_40.2
processor.resource_44.3
ROMHeader_E0
vampire.resource_45.3
VampireBoot_1.7(Apollo_G28)
VampireSupport_40.14
workbench.library_40.5




Henryk Richter

Posts 93
30 Sep 2018 14:29


Peter Heginbotham wrote:

  How does effect the extend rom modules in the vampire rom and are these to be avalible.

The utilities bundle the essential modules and concatenate them on-the-fly with the user-provided kick before Mapping or Flashing.

Please note that anything before Gold 2.10 was not tested and I would advise against attempts to flash the ROM on older Cores.


Henryk Richter

Posts 93
30 Sep 2018 14:36


Vojin Vidanovic wrote:

    I would expect Vamp ROM to improve on its own using OS 3.9/AROS//EmuTOS/MacClassic ROMs as basis and without 512KB limit. Real usable Kickstart in ROM, what NGs can only dream of. You cant have it all, at least not in Amiga World.

I applaud your enthusiasm but please don't stray too far off the mark with your wish list.

The tools announced in this thread will flash or map 3.1.4 which has been tested specifically. In fact, they will only accept valid Amiga Kickstart ROMs. No promises are made with respect to custom ROMs. They may or may not work as intended.


Sean Sk

Posts 189
30 Sep 2018 14:37


Niclas A wrote:

Would be nice to include 3.1.4 in Vampire 4 instead of 3.1 maybe. but if the team already have a nice deal with 3.1 roms then better leave it to the user.

 
Yes that's understandable.
 
One thing I forgot to mention in my last post was that if Apollo did enter into a license agreement to include 3.1.4 ROMS in the Apollo Core and it was necessary to charge the end-user for it, I would certainly be willing to pay. But that's just my opinion, others may disagree. :)


Peter Heginbotham

Posts 156
30 Sep 2018 19:08


So if i create a 1MB rom i don't need to include the vampire specific modules


Vojin Vidanovic

Posts 736
30 Sep 2018 19:47


Henryk Richter wrote:

  I applaud your enthusiasm but please don't stray too far off the mark with your wish list.
  In fact, they will only accept valid Amiga Kickstart ROMs.

AROS and EmuTOS is in Amiga format, we would need "to convert" MacROM only to make that list fully true. Maybe NeoGeo ROM too? :-) One core flash different ROMs to kick the machine would be great and innovative approach.



Henryk Richter

Posts 93
30 Sep 2018 20:15


Peter Heginbotham wrote:

So if i create a 1MB rom i don't need to include the vampire specific modules

1 MB ROMs won't be accepted by these tools. You can still use VControl to map 1 MB ROMs at your discretion, though.

Sadly, we don't have sufficient free space in Flash for 1 MB ROMs. The ROM is packed in order to fit both the regular Kickstart and the Vampire specific modules. A fully loaded 1 MB ROM will simply not fit in the available V2 Flash space.

But good point about workbench.library. That is indeed something to be mentioned. The OS 3.1.4 is not ROM-able (same as the one from 3.9). Therefore you need to have workbench.library as well as icon.library in libs:


Sean Sk

Posts 189
01 Oct 2018 01:04


Well OS 3.1.4 has been released officially now.
 
OK So I'm not terribly knowledgeable on these things so please bear with me.
 
It seems it's not absolutely necessary to use the KS 3.1.4 ROM for OS 3.1.4 as, if you have an older KS 3.1 ROM (or the Vampire ROM in this case), the OS can still be installed but you will need to use the included Modules Disk in the installation.
 
On the EAB forum post it is stated: "We recommend the A1200 bundle for Vampire owners." So would that mean we would need to use the "ModulesA1200_3.1.4" instead of "ModulesA600_3.1.4" (for V600) or "ModulesA500_3.1.4" (for V500)? Remember this is if we chose NOT to flash KS 3.1.4 or MapROM it (I think).
 
Just some clarification needed for my dumb brain. :)

EDIT: Apparently ROM chips will be released a little later.

posts 97page  1 2 3 4 5